View Single Post
  #1  
Old 08-15-2012, 10:33 PM
Starbom's Avatar
Starbom Offline
 
Join Date: Dec 2011
Posts: 321
Default HELP! My DS is....

Story: I was playing my DS last night, my power went to red, and so I decided to plug the charger in by the microwave. Somebody had moved it onto the counter that was wet from dishes. I went to pick up my DS to do the Royal Unova daily event on PKMN white and it was soaked. I dried it off with a cloth, turned it on and it worked fine.

More water was dripping out so I shut down, took out my GBA and DS games, blew all the water out then turned it on again. This time I got a blank black screen. I wiped it down and cleaned it again. Got another black screen.

After the 3rd time, it worked, I went to the boat, battled a youngster, then went to battle a clerk male's Ariados when I got Magmortar to use flamethrower.

Now when I clicked it, it brought me to the screen as if i went to my party, clicked magmortar and pressed "Check moves". With this going down I cant attack. I thought it may of just been the bottom right hand attack, so I tried thunderbolt (Which I used to defeat the youngster) and I got the same "Check moves" interface. Shut down, cleaned DS again, and tried again. Still not working.

Help please? I dont have money for a new DS, and Im already saving to replace my YLOD'd PS3.


TL;DR: DS is wet, I dried it and its still not working at 100%. Need help to repair it.
Reply With Quote